Duplicate Transactions - PayPal, Citi, ING and Macquarie Bank

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 10:03 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 18, 2025 - 15:04 AEDT

Update

We are continuing to investigate this issue.
Posted Mar 18, 2025 - 15:04 AEDT

Update

We are continuing to investigate this issue.
Posted Feb 24, 2025 - 17:01 AEDT

Investigating

PayPal, Citi, and ING have been providing duplicate transactions on some accounts. We have logged a case which each bank.
Posted Feb 24, 2025 - 16:47 AEDT
This incident affected: CDR Data Holders (Banks and other Financial Institutions) (Macquarie Bank, ING Bank, PayPal Australia, CitiBank).